Cacti – Using custom templates

Cacti is an awesome tool, but what really makes it fun is importing templates to graph different kinds of data. Here’s a list of custom templates, and there are a lot more out there…

Each one might vary a bit on how it is imported (perl script added to /cacti/scripts, etc.) but the basic ones simply require a .xml to be imported right from the web interface.

Here’s an example of the Cisco 800 series ADSL template:

Cacti Graph - Cisco 857 DSL info

Share

Share

DSL Terminology: ATU-C/R

ATU-C/R are fancy words for ADSL modems:

ATU-C ADSL Termination Unit – Central (Office) The ATU-C is packaged into Central Office type equipment (ISP or Telco ADSL modem).

ATU-R ADSL Termination Unit – Remote The ATU-R is a self-contained box suitable for customer use, including an AC adapter for powering (End user ADSL modem).

You’ll find these in the (Cisco) output of show dsl interface

Taken from DSLreports.com

Share

Share

Get DSL statistics from your Cisco modem

show dsl interface ATM

An example from cisco.com:

router# show dsl int atm0
Alcatel 20150 chipset information

ATU-R (DS) ATU-C (US)
Modem Status: Showtime (DMTDSL_SHOWTIME)
DSL Mode: ITU G.992.1 (G.DMT)
ITU STD NUM: 0x01 0x1
Vendor ID: 'ALCB' 'ALCB'
Vendor Specific: 0x0000 0x0000
Vendor Country: 0x00 0x0F
Capacity Used: 85% 98%
Noise Margin: 13.5 dB 7.0 dB
Output Power: 9.5 dBm 12.0 dBm
Attenuation: 1.5 dB 3.5 dB
Defect Status: None None
Last Fail Code: None
Selftest Result: 0x00
Subfunction: 0x15
Interrupts: 5940 (0 spurious)
PHY Access Err: 0
Activations: 1
SW Version: 3.670
FW Version: 0x1A04

Interleave Fast Interleave Fast
Speed (kbps): 0 8128 0 864
Reed-Solomon EC: 0 0 0 0
CRC Errors: 0 0 0 7
Header Errors: 0 0 0 2
Bit Errors: 0 0
BER Valid sec: 0 0
BER Invalid sec: 0 0

DMT Bits Per Bin
00: 0 0 0 0 0 0 0 7 6 7 9 A B C C C
10: C C C C C C B B B B A 9 A 9 0 0
20: 0 0 0 0 0 0 2 2 3 4 4 5 6 6 7 7
30: 7 8 8 8 9 9 9 A A A A A A B B B
40: B B B B B B B B B B B A B B B B
50: B B B B B B B B B B B B 2 B B B
60: B B B B B B B B B B B B B B B B
70: B B B B B B B B B B B B B B B B
80: B B B B B B B B B B B B B B B B
90: B B B B B B B B B B B B B B B B
A0: B B B B B B B B B B B B B B B B
B0: B B B B B B B B B B B B A B A A
C0: A A A A A A A A A A A A A A A A
D0: A A A A A A A A A A A 9 9 9 9 9
E0: 9 9 9 9 9 9 9 9 9 9 9 9 8 8 8 8
F0: 8 8 8 8 8 8 7 7 7 7 6 6 5 5 4 4

DSL – SNR, Attenuation, and CRC’s (taken from DSLreports.com)

SN Margin (AKA Signal-to-Noise Margin or Signal-to-Noise Ratio)
Relative strength of the DSL signal to Noise ratio. 6dB is the lowest dB manufactures specify for modem to be able to sync. In some instances interleaving can help raise the noise margin to an acceptable level. The higher the number the better for this measurement.
6dB or below is bad and will experience no sync or intermittent sync problems
7dB-10dB is fair but does not leave much room for variances in conditions
11dB-20dB is good with no sync problems
20dB-28dB is excellent
29dB or above is outstanding

Line Attenuation
Measure of how much the signal has degraded between the DSLAM and the modem. Maximum signal loss recommendation is usually about 60dB. The lower the dB the better for this measurement.
20dB and below is outstanding
20dB-30dB is excellent
30dB-40dB is very good
40dB-50dB is good
50dB-60dB is poor and may experience connectivity issues
60dB or above is bad and will experience connectivity issues

CRC Errors (Cyclic Redundancy Check)
CRC is a method of detecting errors in data transmission. A high CRC count in itself is not really cause for alarm. However, any increase in CRCs after your initial connection is established is a problem and usually points to a physical issue somewhere.

thanks again, Chris!

Share

Share

Cisco 857 DSL Sync – DSL present on the line?

Was setting up DSL at a new site today and couldn’t get the ‘CD’ light to come on at all on a Cisco 857, no flashing, nothing. Seemed as though there was no DSL signal detected on the line. Turns out that the you can have the Dialer interface and ATM sub-interface up, but if the ATM interface is not up, you will not get any CD light activity. You also won’t get the usual clicking noise that the device makes when it is trying to sync up, as it, well, ISN’T trying to sync up.

Check out the post on Cisco DSL stats for Cisco DSL troubleshooting info.

Share

Cisco 857 config example



The Cisco 857 is an awesome solution for reliable, flexible, remotely maintainable DSL connectivity. Check out the post on Cisco DSL stats for Cisco DSL troubleshooting info.

Here’s an example configuration of a Cisco 857 (ADSL router) with some of the [variables in brackets]:

!
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname
[hostname]
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5
[yoursecretpassword]
enable password 7
[yourpassword]
!
username
[username] password 7 [username’s password]
no aaa new-model
ip subnet-zero
ip dhcp excluded-address
[start address for NON-DHCP] [end address for NON-DHCP]
ip dhcp excluded-address
[start address for NON-DHCP] [end address for NON-DHCP]
!
ip dhcp pool
[NameofDHCPpool]
network
[network address] [subnet mask]
dns-server
[address of DNS server]
default-router
[address of default router]
!
ip cef
ip domain name
[ip domain name, like ‘my.domain.name’]
no ftp-server write-enable
!
[crypto pki trustpoint info removed for brevity]
!
interface ATM0
no ip address
ip virtual-reassembly
no snmp trap link-status
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc
[pvi]/[pci]
encapsulation
[obtained from your ISP, ‘aal5mux ppp dialer’ is an example]
dialer pool-member 1
!
interface FastEthernet0
description
[Name/Description of Interface]
no ip address
!
interface FastEthernet1
no ip address
shutdown
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface Vlan1
ip address
[network addy for LAN] [subnet mask]
!
interface Dialer0
ip address negotiated
ip access-group 101 in
encapsulation ppp
dialer pool 1
dialer-group 2
ppp chap hostname
[PPP chap user]
ppp chap password 7
[PPP chap password]
ppp pap sent-username
[PPP pap user] password 7 [PPP pap user]
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http authentication local
ip http secure-server
!
access-list 101 permit ip
[permitted network addy] [inverse subnet mask] any
access-list 101 permit ip host
[permitted ip] any
access-list 101 deny ip any any
dialer-list 2 protocol ip permit
!
control-plane
!
banner motd ^C
[put your MOTD banner here! maybe check out the previous post on MOTD banners]^C
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
password 7
[vty password]
login local
transport preferred all
transport input ssh
transport output all
!
scheduler max-task-time 5000
end

Share

Share